Forum

Notifications
Clear all

[Solved] Difficulty running Homer3 'undefined function "makecform" for input argumentes of type "char" '

4 Posts
2 Users
0 Likes
103 Views
Posts: 7
Topic starter
(@inlava)
Active Member
Joined: 2 months ago

Hi Homer experts,

I installed Homer3-1.80.2 and would like to run it from source in Matlab (R2017b on a Windows PC). I set the paths as recommended.

While it initially starts (and shortly opens some GUI windows), an error comes up, which I did not find documented anywhere.

I pasted the error below.

Any help is much appreciated! Thanks a lot in advance.

Inla

 

----------------------------------------------

ERROR:    """"Undefined function " makecform"  for input arguments of type " char" .

Current Folder :  D:/Users/im18h650/My Tresors/proj_1902_tsstschmerz/excecution/data/processed/fnirs/homer/

Call stack:

    Error in distinguishable_colors.m > distinguishable_colors (line 93)

    Error in TreeNodeClass.m > TreeNodeClass.CondColTbl (line 2280)

    Error in TreeNodeClass.m > TreeNodeClass.TreeNodeClass (line 82)

    Error in GroupClass.m > GroupClass.GroupClass (line 23)

    Error in DataTreeClass.m > DataTreeClass.DataTreeClass (line 36)

    Error in LoadDataTree.m > LoadDataTree (line 50)

    Error in MainGUI.m > MainGUI_OpeningFcn (line 256)

    Error in gui_mainfcn.m > gui_mainfcn (line 220)

    Error in MainGUI.m > MainGUI (line 19)

    Error in Homer3.m > Homer3 (line 58)

----------------------------------------------

 

To use 'makecform', the following product must be licensed, installed, and enabled:

  Image Processing Toolbox

 

Error in distinguishable_colors (line 93)

    C = makecform('srgb2lab');

 

Error in TreeNodeClass.CondColTbl (line 2280)

            tbl = distinguishable_colors(128);

 

Error in TreeNodeClass (line 82)

            obj.CondColTbl('init');

 

Error in GroupClass (line 23)

            obj@TreeNodeClass(varargin);

 

Error in DataTreeClass (line 36)

            obj.groups              = GroupClass().empty();

 

Error in LoadDataTree (line 50)

    dataTree = DataTreeClass(groupDirs, fmt, procStreamCfgFile);

 

Error in MainGUI>MainGUI_OpeningFcn (line 256)

maingui.dataTree = LoadDataTree(maingui.groupDirs, maingui.format, procStreamFile);

 

Error in gui_mainfcn (line 220)

    feval(gui_State.gui_OpeningFcn, gui_hFigure, [], guidata(gui_hFigure), varargin{:});

 

Error in MainGUI (line 19)

    [varargout{1:nargout}] = gui_mainfcn(gui_State, varargin{:});

 

Error in Homer3 (line 58)

    unitTest = MainGUI(groupDirs, inputFileFormat, unitTest, 'userargs');

 

 

3 Replies
Posts: 7
Topic starter
(@inlava)
Active Member
Joined: 2 months ago

Hi, I inadvertently marked this as solved, but it is not! I hope someone can help!

Thank you so much in adavance, Ines

Reply
Posts: 306
(@dboas)
Joined: 3 years ago

I suspect your version of matlab is too old. I don't know for a fact, but I suggest you download a newer version of matlab. Or just use the executable version of homer3.

Reply
Posts: 7
Topic starter
(@inlava)
Active Member
Joined: 2 months ago

Thank you so much, the version was the problem, it worked now!

Reply
Share:
en_USEnglish