Forum

Notifications
Clear all

(Error) loading data for ImageRecon

Page 1 / 2

Sae
Posts: 14
 Sae
Registered
Topic starter
(@sae)
Active Member
Joined: 8 months ago

 

Hello, Dear...all.

 

I have a question about loading data for ImageRecon in Atlasviewer.

I prepared some files which was needed for processing imagerecon by refering to recture of ImageRecon.

But Following Error was displayed.

---------------------------------------------------------------

Loaded acquisition data in 6.6 seconds

Saved group data, version 1.2 exists

Error using MenuBox
Too many input arguments.

Error in TreeNodeClass/Mismatch (line 686)
configFileOptions = MenuBox('',{},[],[],
'dontAskAgainOptions');

Error in GroupClass/Copy (line 205)
if obj.Mismatch(obj2)

Error in GroupClass/Load (line 609)
obj.Copy(group, 'conditional');

Error in DataTreeClass/LoadGroup (line 314)
obj.groups(iG).Load();

Error in DataTreeClass/FindAndLoadGroups (line 239)
obj.LoadGroup(iGnew, procStreamCfgFile, options);

Error in DataTreeClass (line 74)
obj.FindAndLoadGroups(groupDirs, fmt, procStreamCfgFile,
options);

Error in loadGroupNirsDataFile (line 31)
dataTree = DataTreeClass({},'snirf','','noloadconfig:oneformat');

Error in findSubjDirs>searchDir (line 27)
group = loadGroupNirsDataFile(dirname);

Error in findSubjDirs (line 9)
[subjDirs, groupDir, group] = searchDir(dirname0);

Error in AtlasViewerGUI>InitGroup (line 394)
[subjDirs, groupDir, group] = findSubjDirs();

Error in AtlasViewerGUI>AtlasViewerGUI_OpeningFcn (line 519)
[groupSubjList, dirnameSubj, group] = InitGroup(varargin);

Error in gui_mainfcn (line 220)
feval(gui_State.gui_OpeningFcn, gui_hFigure, [], guidata(gui_hFigure),
varargin{:});

Error in AtlasViewerGUI (line 19)
gui_mainfcn(gui_State, varargin{:});

Error in AtlasViewerGUI>menuItemChangeSubjDir_Callback (line 952)
AtlasViewerGUI(dirnameSubj, dirnameAtlas, fwmodel.mc_exepath, hGroupList,
'userargs');

Error in gui_mainfcn (line 95)
feval(varargin{:});

Error in AtlasViewerGUI (line 19)
gui_mainfcn(gui_State, varargin{:});

Error in
matlab.graphics.internal.figfile.FigFile/read>@(hObject,eventdata)AtlasViewerGUI('menuItemChangeSubjDir_Callback',hObject,eventdata,guidata(hObject))
Error while evaluating Menu Callback.

>>

-------------------------------------------------------------------------

I attatched groupResult.mat file. 

Maybe there is something wrong with the way I am doing things.

 

Any information would greatly help.

 

Sincerely,

 

Sae

 

9 Replies
David Boas
Posts: 158
Registered
(@dboas)
Estimable Member
Joined: 1 year ago

We just made a new release of Homer and AtlasViewer last week just before our virtual training workshop this week and next. This release fixes many many issues with the prior release. We are now encouraging all users to use the releases and not the development version from github. You should get the latest releases for Homer and AtlasViewer and try again.

 

Reply
1 Reply
Sae
 Sae
Registered
(@sae)
Joined: 8 months ago

Active Member
Posts: 14

@dboas 

 

Hello.

I appriciate your help, and I could open the data tree.

 

But there is another problem.

When I clicked "reconstruct image" in ImageReconGUI, following error was displayed. 

----------------------

Error: tHRF is missing from Subject data. Check groupResults.mat use Homer3 to generate new groupResults.mat file

---------------------------

what is this problem?

My group folder has groupResults.mat and each subject folder has snirf file from Homer3, I think.... .

Forthermore, those files was prepared yesterday.

I attatched groupResults.mat I loaded.

 

Regards,

 

Sae

Reply
David Boas
Posts: 158
Registered
(@dboas)
Estimable Member
Joined: 1 year ago

Did you run a GLM or block average in Homer? This seems to suggest that you have no estimation of the HRF. Do you runs have stimulus onsets?

Reply
Sae
Posts: 14
 Sae
Registered
Topic starter
(@sae)
Active Member
Joined: 8 months ago

Hi, David.

 

Yes, I did. I run the data and automatically updated the snirf file.

And I moved the file of snilf in the subject file of Atlasviewer.

How is the situation on this issue?

 

Regards,

 

Sae

Reply
Meryem Yücel
Posts: 94
Moderator
(@mayucel)
Joined: 1 year ago

@sae

Please run homer3 first, and run AV in the same folder. Do not move .snirf our hmroutput elsewhere.

Reply
1 Reply
Sae
 Sae
Registered
(@sae)
Joined: 8 months ago

Active Member
Posts: 14

@mayucel 

 

Hello, Meryem.

 

I really appreciate your help.

I understood that I have to run snirf file and AV file at the same directory.

 

So to confirm, you mean the folder which has function of Atlasviewer(everything from setpath) has to exist under the folder of Homer3 ?

 

I have separated these folder... .

 

Is it my mistake?

 

Thank you in advance.

 

Sincerely,

 

Sae

Reply
Page 1 / 2
Share: