Forum

Notifications
Clear all

Error on adding dummy optodes

4 Posts
4 Users
1 Likes
234 Views
Ali Saeedi
Posts: 1
Topic starter
(@ali-saeedi)
New Member
Joined: 10 months ago

Hi there,

I run a problem while adding a dummy optode to a simple probe: two Tx's at (0,0) and (30,30) and two Rx's at (0,30) and (30,0). The springs' configuration seem exactly as optode configuration (square-shaped). While adding coordinations for dummy optode, this error apears:

-----------------------------------------------------------------

Index in position 2 exceeds array bounds (must not exceed 4).

Error in optode_tbl_GetCellLengths (line 27)
l(jj) = length(tbl_data{r,ii});

Error in optode_dummy_tbl_CellEditCallback (line 25)
[l, tbl_data] = optode_tbl_GetCellLengths(tbl_data, r, coordCols,
handles);

Error in gui_mainfcn (line 95)
feval(varargin{:});

Error in SDgui (line 20)
gui_mainfcn(gui_State, varargin{:});

Error in
matlab.graphics.internal.figfile.FigFile/read>@(hObject,eventdata)SDgui('optode_dummy_tbl_CellEditCallback',hObject,eventdata,guidata(hObject))
Error while evaluating Table CellEditCallback.

-----------------------------------------------------------------

The messege appears for every single time I add/delete a value for any of the (x,y,z) coordinates. However, in the end the vaules stay in the table, but no opt# is added and consequently no optode is added to the probe on the right.

Running AtlasViewer v2.16.1 on MATLAB R2021a on Windows 10.

Would appreciate any help.

With best regards,

Ali Saeedi

3 Replies
Axel Giottonini
Posts: 1
(@axelgiottonini)
New Member
Joined: 8 months ago

Hello Ali,

 

it seems that I had the same problem than you. I fixed it temporary by commenting out lines :

In optode_tbl_GetCellLengths.m: 12, 13, 36 to 52

I also modified at line 18

coordGrommetCols = coordCols(1):grommetRotIdx;

by

coordGrommetCols = coordCols;

In optode_dummy_tbl_CellEditCallback.m: 83 to 87.

 

I will probably try to fix the issue in a better way but for the moment it worked fine.

 

Best,

Axel Giottonini

Reply
David Boas
Posts: 238
(@dboas)
Reputable Member
Joined: 2 years ago

I asked Sreekanth to look into this. He will update us.

But do please note that we are phasing out SDgui in favor of the new 3D probe design method. You can read about how to do that here.

Reply
Sreekanth kura
Posts: 14
(@skurabu-edu)
Joined: 2 years ago

Hi Ali and Axel,

I fixed the above bug in SDgui and pushed to AtlasViewer master branch on Github. Sorry for the delay, I was trying to verify few things before pushing onto master branch. 

Axel, Your temporary solution might work but it didn't fix the main cause. Please use the updated master branch if you are planning to use SDgui for probe design. 

As David suggested, I encourage you to use AtlasViewer new 3D probe design. Please post your questions here if you have any issues with 3D probe design or SDgui.

Thanks,

Sreekanth

Reply
Share:
en_USEnglish