Forum

Notifications
Clear all

Register probe to surface

6 Posts
2 Users
2 Likes
860 Views
Joanna Wysocka
Posts: 12
Topic starter
(@joawys)
Active Member
Joined: 2 years ago

Hi everyone,

 

I have a question regarding Atlas Viewer (I am using the latest release). We have collected the coordinates of optodes and reference points using 3d scanner - these coordinates are saved in the digpts file. Unfortunately, after successfully registering atlas to digpts, the option “register probe to surface” seems to be unavailable. Do you have any idea why it might be happening? I would be really grateful for your suggestions. In case it is somehow helpful, I am sending our probe as well as exemplary .SNIRF and digpts file: https://we.tl/t-HbWueFpr4U&source=gmail&ust=1612891777785000&usg=AFQjCNFiO9F2v5WmTEmnRFXBQHAFwEjFt A"> https://we.tl/t-HbWueFpr4U  

 

Best regards,

Joanna

Topic Tags
5 Replies
David Boas
Posts: 237
(@dboas)
Reputable Member
Joined: 2 years ago

You didn't say anything about an SD file. You need an SD file indicating the list of measurements with the given sources and detectors.

More details are here

https://github.com/BUNPC/AtlasViewer/wiki/Registering-Atlas-to-Digital-Points

It does mention the need for the SD file. It could be more explicit no doubt.

 

The lecture in Day 6 of our training course covers it as well

https://openfnirs.org/training/homer-premium/training-courses/20201019-member/fnirs-course-day-7-october-28/

 

Reply
Joanna Wysocka
Posts: 12
Topic starter
(@joawys)
Active Member
Joined: 2 years ago

Dear David,

 

we do have our SD file in the subject's folder. After registering atlas to digpts it looks like this, so I suppose that the probe has ben succesfully imported? Channels are displayed in its correct location, but "register probe to surface" option is still disabled. 

Reply
David Boas
Posts: 237
(@dboas)
Reputable Member
Joined: 2 years ago

Sorry about that... I should have downloaded your zip file first. Indeed, register atlas to dig points is working...

your digpts also has all of the coordinates of the sources and detectors and so they take on those positions.

If you only want to use digpts to get the head size and not the optode positions, then you can remove the optode positions from the digpts.txt file. I just tried this... but the register probe to surface was still grayed out. I know Jay was fixing something with this button the past week... but I don't think he pushed it to github yet. Hopefully this will be fixed soon.

There use to be a way to pull digitzed optode positions to the head surface. Your digitized optodes are clearly several mm above the head surface likely because you digitized the top of the optodes, which makes sense. The code use to then pull them to the surface. I have to look into what is happening with that.

Reply
Joanna Wysocka
Posts: 12
Topic starter
(@joawys)
Active Member
Joined: 2 years ago

Sure, thank you! I would be grateful if you could keep me posted on that.

I also wanted to ask a Homer-related question: is adding in variable trial duration in the GLM already available?

Reply
Page 1 / 2
Share:
en_USEnglish