Forum

Notifications
Clear all

Trouble with DataTree and ImageRecon in AtlasViewer V2. 16.1

18 Posts
6 Users
0 Reactions
1,070 Views
Posts: 1
Topic starter
(@kabella)
New Member
Joined: 2 years ago

Hello everyone,

I have trouble loading groups in AtlasViewer V2.16.1 (the latest). I can't call forth the DataTreeGUI therefore the ImageReconGUI can't identify my group and subject(s) to do reconstruction. I structure my maps and files for image reconstruction according to https://github.com/BUNPC/AtlasViewer/wiki. My GroupResult.mat input is from Homer3 1.54.0 (the latest). I run these with MATLAB R2017b (onWin10). This problem occurs with all my data, even data that once worked with Homer2&AtlasViewer package. Homer3 creates a different groupresult structure than Homer2, perhaps this could be the culprit or I do something serially wrong. Please help me to find out the problem! I shared a drive link leads to one of my data packs with one subject and a screenshot about the situation.

https://drive.google.com/drive/folders/1IrTmLz-Isb-RgiJFNIzF6xWM1VwA2gol?usp=share_link

 

Kind regards,

Balint Kabella

17 Replies
Posts: 13
(@afiske)
Active Member
Joined: 4 years ago

Hello! I have a similar problem in that because the groupResults file produced by Homer3 doesn't contain the same information as the groupResults file that Homer2 used to produce. This means that I am unable to use some analysis scripts (which the author of the scripts kindly allowed us to use) that require the format of the Homer2 groupResults file. Is there a way that I can ask Homer3 to procude the groupResults file in the same way as Homer2, or is there a way to combine the two datafiles output by Homer3 so that they are in the same format as the old Homer2 groupResults file?

 

Many thanks,

Abi

Reply
Posts: 10
(@tharenk)
Active Member
Joined: 1 year ago

Hi! I believe I've encountered the same problem - is there an update on this issue?

Reply
Posts: 309
(@dboas)
Joined: 4 years ago

Jay has told me that the latest AtlasViewer development branch has been updated to be compatible with the latest Homer output.

Let us know if this resolves your issues.

Reply
Posts: 10
(@tharenk)
Active Member
Joined: 1 year ago

Hi David, thank you for your response and Jay for releasing a new update (v2.18.1). I've tried running it however, I've still had no luck calling forth the DataTreeGUI. I've added three screenshots (see replies to this thread), two of which show some warning messages I've been getting, and another shows that my group is being added to the dataTree. 

Any guidance would be greatly appreciated, 

Thanks in advance,

Tharen

Reply
4 Replies
(@tharenk)
Joined: 1 year ago

Active Member
Posts: 10
(@tharenk)
Joined: 1 year ago

Active Member
Posts: 10
(@tharenk)
Joined: 1 year ago

Active Member
Posts: 10

group being added to dataTree 

Reply
Registered
(@laserlab)
Joined: 1 year ago

Active Member
Posts: 5

@tharenk Hi, I'm having a similar issue. I'm not able to see my subject/ group results in the ImageRecon GUI. Were you able to resolve it?

Reply
Page 1 / 2
Share:
en_USEnglish